GCP Cloud Experiencing increased latency
Incident Report for Blameless
Resolved
Services are back to normal
Posted Dec 07, 2023 - 19:47 UTC
Monitoring
GCP Cloud Experiencing increased latency affecting some services in Blameless. We are monitoring our logs and GCP.
Posted Dec 05, 2023 - 18:20 UTC
This incident affected: Blameless Incident Management, Slack Messaging, and Slack Apps/Integrations.