Incidents List not loading as expected
Incident Report for Blameless
Resolved
This incident was isolated to one customer instance and has been resolved.
Posted Jun 21, 2023 - 18:21 UTC
Investigating
Some customers are reporting that the incidents list is not loading as expected. We have opened an incident to investigate and will provide updates as the investigation progresses.
Posted Jun 21, 2023 - 17:47 UTC
This incident affected: Blameless.io.